
<!DOCTYPE html>
<html lang="fr">
    <head>
        <title>PySimpleGUI</title>
        <meta name="theme-color" content="rgba(255, 255, 255, 1)">
        <meta name="msapplication-navbutton-color" content="rgba(255, 255, 255, 1)">
        <!-- METATAGS -->
        <!-- rebirth / sail -->
<!--[if IE]>
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<![endif]-->
<meta charset="utf-8">
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no">
    <link rel="alternate" type="application/rss+xml" href="http://www.miamondo.org/blog/do/rss.xml" />
    <meta name="twitter:title" content="PySimpleGUI"/>
    <meta property="og:title" content="PySimpleGUI"/>
    <meta property="og:url" content="http://www.miamondo.org/blog/mon-retour-d-experience-avec-pysimplegui.html"/>
    <meta property="og:type" content="article"/>
    <meta name="description" content="La semaine dernière, alors que j'étais plongé dans le code de mon environnement de bureau fait maison, je me suis demandé sil existait des alternatives à l'interface graphique Tkinter. Il en existe.  L'une d'entre elles a tout particulièrement retenu mon attention. Il s'agit de PySimpleGUI."/>
    <meta name="twitter:description" content="La semaine dernière, alors que j'étais plongé dans le code de mon environnement de bureau fait maison, je me suis demandé sil existait des alternatives à l'interface graphique Tkinter. Il en existe.  L'une d'entre elles a tout particulièrement retenu mon attention. Il s'agit de PySimpleGUI."/>
    <meta property="og:description" content="La semaine dernière, alors que j'étais plongé dans le code de mon environnement de bureau fait maison, je me suis demandé sil existait des alternatives à l'interface graphique Tkinter. Il en existe.  L'une d'entre elles a tout particulièrement retenu mon attention. Il s'agit de PySimpleGUI."/>
    <meta name="keywords" content="Python, GUI, tkinter, PySimpleGUI"/>
    <link rel="image_src" href="http://www.miamondo.org/medias/images/pysimplegui.png"/>
    <meta property="og:image" content="http://www.miamondo.org/medias/images/pysimplegui.png"/>
    <meta name="twitter:image" content="http://www.miamondo.org/medias/images/pysimplegui.png"/>
    <meta name="twitter:card" content="summary_large_image"/>
    <link rel="canonical" href="http://www.miamondo.org/blog/mon-retour-d-experience-avec-pysimplegui.html">
<meta name="generator" content="e-monsite (e-monsite.com)">

<link rel="icon" href="http://www.miamondo.org/medias/site/favicon/miamondo_29.png">
<link rel="apple-touch-icon" sizes="114x114" href="http://www.miamondo.org/medias/site/mobilefavicon/miamondo_29-1.png?fx=c_114_114">
<link rel="apple-touch-icon" sizes="72x72" href="http://www.miamondo.org/medias/site/mobilefavicon/miamondo_29-1.png?fx=c_72_72">
<link rel="apple-touch-icon" href="http://www.miamondo.org/medias/site/mobilefavicon/miamondo_29-1.png?fx=c_57_57">
<link rel="apple-touch-icon-precomposed" href="http://www.miamondo.org/medias/site/mobilefavicon/miamondo_29-1.png?fx=c_57_57">


            <link href="https://fonts.googleapis.com/css?family=Roboto:300,300italic,400,400italic,700,700italic%7CRoboto%2BCondensed:300,300italic,400,400italic,700,700italic&display=swap" rel="stylesheet">

    <link href="//www.miamondo.org/themes/combined.css?v=6_1592292048_679" rel="stylesheet">


<script src="//www.miamondo.org/medias/static/themes/bootstrap_v4/js/jquery-3.4.1.min.js"></script>
<script src="//www.miamondo.org/medias/static/themes/bootstrap_v4/js/popper.min.js"></script>
<script src="//www.miamondo.org/medias/static/themes/bootstrap_v4/js/bootstrap.min.js"></script>
    <script src="//www.miamondo.org/themes/combined.js?v=6_1592292048_679"></script>



        <!-- //METATAGS -->
            <script src="//www.miamondo.org/medias/static/jqueryCuttr/jquery.cookie.js"></script>
    <script src="//www.miamondo.org/medias/static/jqueryCuttr/jquery.cookiecuttr.js"></script>
    <script>
    $(document).ready(function(){
        $.cookieCuttr({
            cookieNotificationLocationBottom : true,
            cookieDeclineButton : true,
            cookieResetButton : false,
            cookieAcceptButtonText :'Accepter\u0020les\u0020cookies',
            cookieDeclineButtonText :'Refuser\u0020les\u0020cookies',
            cookieResetButtonText : 'R\u00E9initialiser\u0020les\u0020cookies',
            cookieAnalyticsMessage : 'En\u0020cliquant\u0020vous\u0020acceptez\u0020le\u0020d\u00E9p\u00F4t\u0020de\u0020cookies\u0020destin\u00E9s\u0020au\u0020suivi\u0020des\u0020visites\u0020sur\u0020notre\u0020site,\u0020\u00E0\u0020l\u0027affichage\u0020des\u0020boutons\u0020de\u0020partage\u0020et\u0020aux\u0020remont\u00E9es\u0020de\u0020contenus\u0020des\u0020plateformes\u0020sociales.',
            cookieWhatAreLinkText : ''      
        });
    });
    </script>
        <script>
if(jQuery.cookie('cc_cookie_accept') == "cc_cookie_accept"){
 
    (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
    (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
    m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
    
    ga('create', 'UA-874445-14', 'auto', 'brandTracker');
    ga('brandTracker.send', 'pageview', {
        'dimension1' : 'false', /* Eco */
        'dimension2' : 'e-monsite', /* Brand */
        'dimension3' : 'fr', /* Lang */
        'dimension4' : 'true', /* Pro */
        'dimension5' : 'true', /* Domain */
    });
}
 
</script>
<!-- Google Tag Manager -->
    <script>
    (function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
    j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
    'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
    })(window,document,'script','dataLayer','GTM-PVHF9DL');</script>
<!-- End Google Tag Manager -->
                
        <script src="//www.miamondo.org/medias/static/themes/ems_framework/js/masonry.pkgd.min.js"></script>
        <script src="//www.miamondo.org/medias/static/themes/ems_framework/js/imagesloaded.pkgd.min.js"></script>
    </head>
    <body id="blog_run" data-template="default">
        
        
                
        <!-- NAVBAR -->
                                                                                                                                    <nav class="navbar navbar-expand-lg py-lg-4 position-sticky" id="navbar" data-animation="sliding">
                        <div class="container">
                                            <a class="navbar-brand d-inline-flex align-items-center" href="http://www.miamondo.org/">
                                            <img src="http://www.miamondo.org/medias/site/logos/miamondo-blanc_2.png" alt="miamondo" class="img-fluid brand-logo mr-2 d-none">
                                                            <span class="brand-titles d-lg-flex flex-column align-items-start">
                        <span class="brand-title d-none">Miamondo</span>
                                            </span>
                                    </a>
                                                <button class="navbar-toggler collapsed" type="button" data-toggle="collapse" data-target="#menu">
                    <span></span>
                    <span></span>
                    <span></span>
                    <span></span>
                </button>
                                <div class="collapse navbar-collapse flex-lg-grow-0 mx-lg-auto" id="menu">
                                            <ul class="navbar-nav navbar-menu nav-left">
                                                                                                                    <li class="nav-item" data-index="1">
                <a class="nav-link" href="http://www.miamondo.org/">
                Accueil
                </a>
                                            </li>
                                                                                                                    <li class="nav-item" data-index="2">
                <a class="nav-link" href="http://www.miamondo.org/blog/liste-des-articles-de-la-rubrique-informatique.html">
                Informatique
                </a>
                                            </li>
                                                                                                                    <li class="nav-item" data-index="3">
                <a class="nav-link" href="http://www.miamondo.org/blog/politique.html">
                Politique
                </a>
                                            </li>
                                                                                                                                                    </ul>
                <a class="navbar-brand d-none" href="http://www.miamondo.org/">
                                        <img src="http://www.miamondo.org/medias/site/logos/miamondo-blanc_2.png" alt="miamondo" class="img-fluid brand-logo d-none">
                                                            <span class="brand-titles d-lg-flex flex-column">
                        <span class="brand-title d-none">Miamondo</span>
                                            </span>
                                    </a>
            <ul class="navbar-nav navbar-menu nav-right">
                                    <li class="nav-item dropdown" data-index="4">
                <a class="nav-link dropdown-toggle" href="http://www.miamondo.org/pages/le-langage-python/">
                Le langage Python
                </a>
                                                <div class="collapse dropdown-menu">
                    <ul class="list-unstyled">
                                                                                                                                                                                                                            <li class="dropdown">
                        <a class="dropdown-item dropdown-toggle" href="http://www.miamondo.org/pages/le-langage-python/mes-programmes-python/">
                        Mes programmes Python
                        </a>
                                                                        <div class="collapse dropdown-menu dropdown-submenu">
                            <ul class="list-unstyled">
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mes-programmes-python/kalkulilo-calculatrice.html">Kalkulilo (calculatrice)</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mes-programmes-python/un-de-numerique.html">Un dé numérique</a>
                                </li>
                                                                <li class="dropdown-menu-root">
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mes-programmes-python/">Mes programmes Python</a>
                                </li>
                            </ul>
                        </div>
                                                </li>
                                                                                                                                                                                                                            <li class="dropdown">
                        <a class="dropdown-item dropdown-toggle" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/">
                        Mon manuel d'apprentissage
                        </a>
                                                                        <div class="collapse dropdown-menu dropdown-submenu">
                            <ul class="list-unstyled">
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/chapitre-1.html">0 - Outils pour coder</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/declarer-une-variable-et-lui-affecter-une-valeur.html">1 - Déclarer une variable</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/3-les-conditions.html">2 - Les conditions</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/4-les-boucles.html">3 - Les boucles</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/4-les-booleens-1.html">5 - Les booléens</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/6-les-fonctions.html">6 - Les Fonctions</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/7-les-modules.html">7 - importer un module</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/methodes-sur-les-objets-de-type-str.html">8 - Méthodes pour str()</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/9-les-listes.html">9 - Les listes</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/10-les-references-partagees-et-le-module-copy.html">10 - Les références partagées</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/11-la-comprehension-de-liste.html">11 - La compréhension de liste</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/12-les-tuples.html">12 - Les tuples</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/13-les-dictionnaires.html">13 - Les dictionnaires</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/14-les-ensembles.html">14 - Les ensembles</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/15-les-fichiers.html">15 - Les fichiers</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/16-le-module-os.html">16 - Le module OS</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/17-le-module-pickle.html">17 - Le module pickle</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/18-classes-et-methodes.html">18 - Classes et méthodes</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/19-classes-et-methodes-2.html">19 - Classes et méthodes (2)</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/20-variables-et-espaces-de-noms.html">20 - Espaces de noms</a>
                                </li>
                                                                <li class="dropdown-menu-root">
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/mon-manuel-d-apprentissage/">Mon manuel d'apprentissage</a>
                                </li>
                            </ul>
                        </div>
                                                </li>
                                        <li class="dropdown-menu-root">
                        <a class="dropdown-item" href="http://www.miamondo.org/pages/le-langage-python/">Le langage Python</a>
                    </li>
                    </ul>
                </div>
                            </li>
                                                                                                                                                                <li class="nav-item dropdown" data-index="5">
                <a class="nav-link dropdown-toggle" href="http://www.miamondo.org/pages/reflexions-personnelles/">
                Réflexions personnelles
                </a>
                                                <div class="collapse dropdown-menu">
                    <ul class="list-unstyled">
                                                                                                                                                                                                                            <li class="dropdown">
                        <a class="dropdown-item dropdown-toggle" href="http://www.miamondo.org/pages/reflexions-personnelles/l-espace-temps/">
                        L'espace-temps
                        </a>
                                                                        <div class="collapse dropdown-menu dropdown-submenu">
                            <ul class="list-unstyled">
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/reflexions-personnelles/l-espace-temps/qui-a-ecrit-la-toute-premiere-ligne-de-code.html">La toute 1ère ligne de code</a>
                                </li>
                                                                <li>
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/reflexions-personnelles/l-espace-temps/l-acceleration-du-temps-au-cours-de-la-vie-sur-terre.html">L'inexorable accélération</a>
                                </li>
                                                                <li class="dropdown-menu-root">
                                    <a class="dropdown-item" href="http://www.miamondo.org/pages/reflexions-personnelles/l-espace-temps/">L'espace-temps</a>
                                </li>
                            </ul>
                        </div>
                                                </li>
                                        <li class="dropdown-menu-root">
                        <a class="dropdown-item" href="http://www.miamondo.org/pages/reflexions-personnelles/">Réflexions personnelles</a>
                    </li>
                    </ul>
                </div>
                            </li>
                                                                                                                    <li class="nav-item" data-index="6">
                <a class="nav-link" href="http://www.miamondo.org/contact/">
                Contact
                </a>
                                            </li>
                </ul>
    
                                        <ul class="navbar-nav navbar-widgets ml-lg-4">
                                                <li class="nav-item d-none d-lg-block">
                            <a href="javascript:void(0)" class="nav-link search-toggler"><i class="material-icons">search</i></a>
                        </li>
                                                                    </ul>
                                                                <ul class="website-social-links">
        <li>
        <a href="https://twitter.com/miamondo_BM" class="btn text-twitter"><i class="sn-icon-twitter"></i></a>
    </li>
    </ul>
                                        
                                        
                                        <form method="get" action="http://www.miamondo.org/search/site/" id="navbar-search" class="fade">
                        <input class="form-control form-control-lg" type="text" name="q" value="" placeholder="Votre recherche" pattern=".{3,}" required>
                        <button type="submit" class="btn btn-link btn-lg"><i class="material-icons">search</i></button>
                        <button type="button" class="btn btn-link btn-lg search-toggler d-none d-lg-inline-block"><i class="material-icons">clear</i></button>
                    </form>
                                    </div>
                        </div>
                    </nav>
        
        <!-- HEADER -->
                                                        <header id="header">
                                                                                    
    <div id="slider-5f5df48510d6c00065e2b54f" class="carousel slide" data-height="auto" data-ride="carousel" data-interval="2000">
                <div class="carousel-inner">
                        <div class="carousel-item active">
                                                        <img src="http://www.miamondo.org/medias/images/miamondo-2.jpg" alt="Miamondo" class="carousel-img img-fluid">
                                                                    <div class="carousel-caption">
                                        <p>Miamondo</p>
                                                        </div>
                            </div>
                    </div>
            </div>
                
        
        <style>
    #slider-5f5df48510d6c00065e2b54f{
        --carousel-bg: transparent;
        --carousel-caption-bg: transparent;
                --carousel-height: auto;
         
    }
        </style>
    
                                    </header>
                <!-- //HEADER -->
        
        <!-- WRAPPER -->
                                                                                <div id="wrapper" class="container margin-top">
            
                        <div class="row align-items-lg-start">
                            <section id="main" class="col-lg-9">
                
                                                                        <ol class="breadcrumb">
                    <li class="breadcrumb-item"><a href="http://www.miamondo.org/">Accueil</a></li>
                            <li class="breadcrumb-item active">PySimpleGUI</li>
            </ol>
                                                                
                                                            
                                        <div class="view view-blog" id="view-item">
    <div class="container">
        <div class="row">
            <div class="col">
                                <p class="seo-image text-center">
                    <img src="http://www.miamondo.org/medias/images/pysimplegui.png" alt="Pysimplegui" class="img-fluid mx-auto d-block">
                </p>
                                <h1 class="view-title">PySimpleGUI</h1>
                <p class="metas">
                                        <span class="meta-author">
                        <img class="meta-avatar rounded d-none d-sm-inline-block" src="https://manager.e-monsite.com/static/manager/im/avatar.png?fx=c_50_50" alt="miamondo">
                        <span>
                            Par 
                            <a href="http://www.miamondo.org/blog/do/author/5e49189107d6b96c0b00561e" rel="author">miamondo</a>    
                        </span>
                    </span>
                                        <span class="meta-date">
                        Le 12/09/2020 
                                                <span class="meta-time">à 23:51</span>
                                            </span>
                                        <span class="meta-comments">
                                                <i class="material-icons">comment</i> <a href="#comments-blog">2</a>                                            </span>
                                    </p>
                                
                <div class="content">
                                        <p>&nbsp;<span style="font-family:courier new,courier,monospace;">Bonjour,</span></p>

<div style="line-height:2;">
<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">La semaine derni&egrave;re, alors que j&#39;&eacute;tais plong&eacute; dans le <strong><a href="http://www.miamondo.org/blog/labortablo-mon-environnement-de-bureau-entierement-code-en-python.html" target="_blank">code de mon environnement de bureau fait maison</a></strong>, je me suis demand&eacute; s&#39;il existait des alternatives &agrave; l&#39;interface graphique <strong><a href="http://tkinter.fdex.eu/" target="_blank">Tkinter</a></strong>. Une rapide recherche sur Internet m&#39;a confirm&eacute; qu&#39;il en existait plusieurs, plus ou moins difficiles et plus ou moins bien document&eacute;es. L&#39;une d&#39;entre elles a tout particuli&egrave;rement retenu mon attention. Il s&#39;agit de <strong><a href="https://pysimplegui.readthedocs.io/en/latest/" target="_blank">PySimpleGUI</a></strong>.</span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;"><strong><a href="https://pysimplegui.readthedocs.io/en/latest/" target="_blank">PySimpleGUI</a></strong> est en grande partie bas&eacute;e sur Tkinter et promet &agrave; l&#39;utilisateur, une exp&eacute;rience de programmation graphique d&#39;une simplicit&eacute; ind&eacute;cente. La structure du code est cens&eacute;e &ecirc;tre beaucoup plus intuitive. S&eacute;duit par ce discours de bonimenteur, j&#39;ai d&eacute;cid&eacute; de voir ce que cet outil avait dans le ventre. J&#39;ai donc remplac&eacute; tkinter par PySimpleGUI dans le programme instanciant <strong><a href="http://www.miamondo.org/blog/labortablo-mon-environnement-de-bureau-entierement-code-en-python.html" target="_blank">mon environnement de bureau personnel</a></strong>. Pass&eacute; l&#39;enthousiasme des premi&egrave;res heures, j&#39;ai vite compris que la simplicit&eacute; allait s&#39;av&eacute;rer plus compliqu&eacute;e que pr&eacute;vue. L&#39;exp&eacute;rience n&#39;a pas r&eacute;pondu &agrave; mes attentes, ce qui ne signifie pas que l&#39;outil n&#39;a aucun int&eacute;r&ecirc;t. C&#39;est juste qu&#39;il ne fonctionne pas.</span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Mais tout d&#39;abord, laissez-moi vous pr&eacute;senter les bases de ce GUI qui diff&egrave;rent de celles de&nbsp;tkinter:&nbsp;</span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Avec tkinter, on instancie d&#39;abord la fen&ecirc;tre m&egrave;re puis on vient y placer des widgets enfants. C&#39;est-&agrave;-dire que la poule pr&eacute;c&egrave;de les oeufs. Cela nous donne:</span></p>

<div style="line-height:1;">
<p><span style="font-family:courier new,courier,monospace;"><a href="http://www.miamondo.org/medias/images/code.png" rel="iframe" title="Code"><img alt="Code" class="img-polaroid" height="234" src="http://www.miamondo.org/medias/images/code.png" width="639" /></a></span></p>

<p style="text-align: center;"><span style="font-family:courier new,courier,monospace;"><a href="http://www.miamondo.org/medias/images/tkinter.png" rel="iframe" title="Tkinter"><img alt="Tkinter" class="img-polaroid" height="79" src="http://www.miamondo.org/medias/images/tkinter.png" width="85" /></a></span><br />
&nbsp;</p>
</div>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Avec PySimpleGUI, c&#39;est le contraire, on instancie d&#39;abord les oeufs dans un layout ( = agencement) avant de les donner &agrave; la poule qui est instanci&eacute;e en dernier. En clair, l&#39;instanciation des widgets enfants pr&eacute;c&egrave;de celle du widget parent.</span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;"><a href="http://www.miamondo.org/medias/images/code2.png" rel="iframe" title="Code2"><img alt="Code2" class="img-polaroid" height="417" src="http://www.miamondo.org/medias/images/code2.png" width="754" /></a></span></p>

<p style="text-align: center;"><span style="font-family:courier new,courier,monospace;"><a href="http://www.miamondo.org/medias/images/pysimple.png" rel="iframe" title="Pysimple"><img alt="Pysimple" class="img-polaroid" height="99" src="http://www.miamondo.org/medias/images/pysimple.png" width="115" /></a></span><span style="font-family:courier new,courier,monospace;"></span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;"><br />
Veuillez noter que la place des accolades dans le layout a toute son importance. Dans le code ci-dessus, les boutons sont agenc&eacute;s sur deux rang&eacute;es diff&eacute;rentes. Si j&#39;eus souhait&eacute; que les boutons eussent &eacute;t&eacute; sur la m&ecirc;me rang&eacute;e, j&#39;eus &eacute;crit ceci :</span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;"><a href="http://www.miamondo.org/medias/images/code3-1.png" rel="iframe" title="Code3 1"><img alt="Code3 1" class="img-polaroid" height="161" src="http://www.miamondo.org/medias/images/code3-1.png" width="607" /></a></span></p>

<p style="text-align: justify;">&nbsp;</p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Voici la traduction de ce qu&#39;&eacute;crit un membre de l&#39;&eacute;quipe PySimpleGUI.&nbsp;Le texte original est <strong><a href="https://pysimplegui.readthedocs.io/en/latest/#the-event-loop-callback-functions" target="_blank">ici</a></strong>: </span></p>

<p style="text-align: justify;"><span style="color:#0000CD;"><span style="font-family:courier new,courier,monospace;"><em>Cette fen&ecirc;tre peut vous sembler &quot;laide&quot;, car aucun effort n&#39;a &eacute;t&eacute; fait pour la rendre agr&eacute;able &agrave; regarder. Elle est purement fonctionnelle. Il y a 30 &eacute;l&eacute;ments dans la fen&ecirc;tre. Trente &eacute;l&eacute;ments. Compte tenu de ce qu&#39;elle fait, <strong>c&#39;est miraculeux ou tout au moins incroyablement impressionnant</strong>. Pourquoi ? Parce qu&#39;en moins de 50 lignes de code, cette fen&ecirc;tre a &eacute;t&eacute; cr&eacute;&eacute;e, affich&eacute;e, a recueilli les r&eacute;sultats et les a affich&eacute;s dans une autre fen&ecirc;tre.</em></span></span></p>

<p style="text-align: justify;"><span style="color:#0000CD;"><span style="font-family:courier new,courier,monospace;"><em>50 lignes. Il vous faudra 50 lignes de code tkinter ou Qt pour obtenir les 3 premiers &eacute;l&eacute;ments de la fen&ecirc;tre &eacute;crite, si vous voulez faire cela.</em></span></span></p>

<p style="text-align: justify;"><span style="color:#0000CD;"><span style="font-family:courier new,courier,monospace;"><em>Non, soyons clairs ici... cette fen&ecirc;tre n&eacute;c&eacute;ssitera une quantit&eacute; massive de code en utilisant les GUI conventionnels. C&#39;est un fait et si vous voulez me prouver que j&#39;ai tort, alors faites-le, s&#39;il vous pla&icirc;t. Veuillez &eacute;crire cette fen&ecirc;tre en utilisant tkinter, Qt, ou WxPyth</em></span><span style="font-family:courier new,courier,monospace;"><em>on et envoyez le code!&nbsp;Notez que cette fen&ecirc;tre a m&ecirc;me une barre de menu en haut, ce qu&#39;on peut facilement ne pas remarquer.</em></span></span></p>

<p style="text-align: justify;">&nbsp;</p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Voici la ci-devant fen&ecirc;tre:</span></p>

<p style="text-align: center;"><a href="http://www.miamondo.org/medias/images/ex2.png" rel="iframe" title="Ex2"><img alt="Ex2" class="img-polaroid" height="403" src="http://www.miamondo.org/medias/images/ex2.png?fx=r_400_403" width="399" /></a></p>

<p style="text-align: justify;">&nbsp;</p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Et voici l&#39;image d&#39;un beau melon:</span></p>

<p style="text-align: center;"><span style="font-family:courier new,courier,monospace;"><a href="http://www.miamondo.org/medias/images/melon.png" rel="iframe" title="Melon"><img alt="Melon" class="img-polaroid" height="407" src="http://www.miamondo.org/medias/images/melon.png" width="396" /></a></span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;"></span></p>

<p style="text-align: justify;">&nbsp;</p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Hein? Non,&nbsp;c&#39;est juste pour faire la transition et encha&icirc;ner sur la diff&eacute;rence de traitement des images entre&nbsp;les deux GUI. Avec tkinter, il faut utiliser <strong><a href="https://fr.wikipedia.org/wiki/Python_Imaging_Library">PIL</a></strong> ou Pillow et traiter les images pour que celles-ci puissent &ecirc;tre affich&eacute;es par le GUI.<br />
Avec <strong>PySimpleGUI</strong>, c&#39;est le Saint-Esprit qui s&#39;en occupe. Vous, vous avez juste &agrave; renseigner le chemin de l&#39;image, pourvu qu&#39;elle soit en <strong>*.png</strong> (comme tkinter), et vous aurez la satisfaction de voir ce beau melon s&#39;afficher&nbsp;sur un bouton par exemple.</span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Donc</span><span style="font-family:courier new,courier,monospace;">, je r&eacute;sume :</span></p>

<ul>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Une syntaxe plus facile et plus intuitive,</span></li>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Pas de gestionnaire de placement proprement dit (<strong>grid()</strong> ou <strong>pack()</strong>). Il suffit de placer les widgets dans des listes,</span></li>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Traitement des images par l&#39;intercession du Saint-Esprit,</span></li>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Une gestion exclusivement command&eacute;e par les &eacute;v&eacute;nements.</span></li>
</ul>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Si vous prenez le temps de fl&acirc;ner</span><span style="font-family:courier new,courier,monospace;">&nbsp;<strong><a href="https://pysimplegui.readthedocs.io/en/latest/" target="_blank">sur le site</a></strong>&nbsp;de PySimpleGUI, dont les pages&nbsp;curieusement, sont un peu longues &agrave; charger, vous d&eacute;couvrirez qu&#39;il est possible de cr&eacute;er des fen&ecirc;tres sympas, qui, comme il est &eacute;crit dans un paragraphe, ne sont pas enlaidies par un design vieillot sorti tout droit des ann&eacute;es 90...</span></p>

<p style="text-align: justify;">&nbsp;</p>

<p style="text-align: center;"><a href="http://www.miamondo.org/medias/images/ex.jpg" rel="iframe" title="Ex"><img alt="Ex" class="img-polaroid" height="402" src="http://www.miamondo.org/medias/images/ex.jpg?fx=r_600_402" width="598" /></a></p>

<p style="text-align: justify;">&nbsp;</p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">En ce qui me concerne, apr&egrave;s avoir &quot;bascul&eacute;&quot; mon code sur pysimpleGUI:</span></p>

<ul>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">l&#39;affichage multi&eacute;crans s&#39;est transform&eacute; en affichage au petit bonheur la chance.</span></li>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Certains boutons du menu principal n&#39;affichent pas les sous-menus.</span></li>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">La barre des t&acirc;ches s&#39;affiche sur un &eacute;cran mais pas sur l&#39;autre, tandis que le menu s&#39;affiche sur l&#39;&eacute;cran qui n&#39;a pas la barre des t&acirc;ches, mais &ccedil;a d&eacute;pend. Parfois, c&#39;est le contraire.</span></li>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Les applications s&#39;ouvrent... ou pas. L&agrave; encore, &ccedil;a d&eacute;pend.</span></li>
	<li style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Le traitement des images est une catastrophe. Mais &ccedil;a d&eacute;pend.</span></li>
</ul>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">En fait, avec PySimpleGUI, j&#39;ai eu l&#39;impression d&#39;&ecirc;tre le t&eacute;moin privil&eacute;gi&eacute;&nbsp;d&#39;une exp&eacute;rience de physique quantique, qui autorise un objet &agrave; se trouver de mani&egrave;re al&eacute;atoire, dans deux &eacute;tats diff&eacute;rents au m&ecirc;me instant.</span></p>

<p style="text-align: justify;"><span style="font-family:courier new,courier,monospace;">Au bout d&#39;une semaine, j&#39;ai capitul&eacute;,<s> je me suis remis &agrave; boire</s>&nbsp;et je suis revenu sur la version tkinter de mon environnement de bureau. M&ecirc;me si ce dernier est toujours en chantier, m&ecirc;me s&#39;il pr&eacute;sente encore de nombreuses imperfections, je l&#39;utilise au quotidien et il est op&eacute;rationnel (sur deux &eacute;crans). PySimpleGUI est, de mon point de vue, une intercouche&nbsp;qui complique inutilement l&#39;utilisation de tkinter, ou qui, pour le dire&nbsp;plus clairement, ne simplifie pas de mani&egrave;re substantielle, la complexit&eacute; toute relative de tkinter. En tout cas, ce qui est s&ucirc;r, c&#39;est que la simplicit&eacute; de PySimpleGUI est bien trop compliqu&eacute;e.</span></p>

<p style="text-align: justify;">&nbsp;</p>

<p style="text-align: center;"><iframe allowfullscreen="" frameborder="0" height="390" src="https://www.youtube.com/embed/ZTeqM5gciH8" title="YouTube video player" width="640"></iframe></p>
</div>

                                    </div>
            </div>
        </div>
    </div>
                   
                         <div id="rows-5f5d1ed65967b96c0b005294" class="rows" data-total-pages="1" data-current-page="1">
                            
                                
        
                                                                            
                        
                                
                        
                        
                                            
                        
                                        
            
                            
                <div id="row-5f5d1ed65967b96c0b005294-1" class="row-container pos-1 page_1 container">
                    <div class="row-content">
                                                                                <div class="row" data-role="line">
                                                                                                                                                                                                                                                                                        
                                                                                                                                                                
                                                                                                                        
                                                                                                                        
                                                                                                                                                                
                                                                                                                            
                                                                                                                                                                                                                                                                                                                    
                                                                                        <div data-role="cell" data-size="lg" class="col empty-column">
                                                <div class="col-content">
                                                                                                            &nbsp;
                                                                                                    </div>
                                            </div>
                                                                                     
                                                                    </div>
                                            </div>
                                    </div>
             
             
</div>

                 
    <div class="container">
        <div class="row">
            <div class="col">
                                <ul class="pager">
                                                            <li class="next-page">
                        <a href="http://www.miamondo.org/blog/labortablo-mon-environnement-de-bureau-entierement-code-en-python.html" class="page-link">
                                                                                                <img src="http://www.miamondo.org/medias/images/labortablo-2.png?fx=c_50_50" width="50" alt="Labortablo, mon environnement de bureau entièrement codé en Python">
                                                                <span>
                                    <strong>Labortablo, mon environnement de bureau entièrement codé en Python</strong><br>
                                    <small>Bonjour,

Le projet avance bien. Je vais mettre en ligne r&eacute;guli&egrave;rement des&nbsp; vid...</small>
                                </span>
                                                        <i class="material-icons">chevron_right</i>
                        </a>
                    </li>
                                    </ul>
                                
                                <p class="tag-line">
                                        <a href="http://www.miamondo.org/blog/do/tag/python/" class="btn btn-outline-secondary btn-sm">Python</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/tkinter/" class="btn btn-outline-secondary btn-sm">Tkinter</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/gui/" class="btn btn-outline-secondary btn-sm">GUI</a>
                                    </p>
                                
                                        
                

<div class="container">
    <div class="row">
        <div class="col">
            <div class="plugins">
                                
                                   <div id="social-5e4ac52bbba7b96c0b0029aa" class="plugin" data-plugin="social">
            <script type="text/javascript"> 
            if(jQuery.cookie('cc_cookie_accept') == "cc_cookie_accept"){ 
               var script = document.createElement('script');        
               var div = document.createElement('div');               
               var container = document.getElementById("social-5e4ac52bbba7b96c0b0029aa");
               
               script.src = "//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-5e00795ac3341b4e";
               div.classList.add("addthis_inline_share_toolbox");
               
               container.append(script);
               container.append(div);         
            }           
        </script>
       
</div>                            
                                   <div class="plugin plugin-rating">
    <form action="http://www.miamondo.org/blog/mon-retour-d-experience-avec-pysimplegui.html" method="post">
        <ul class="rating-list">
                        <li class="note-off">
                <label for="rating1" title="1 / 5">
                    <i class="material-icons">grade</i>
                    <input type="radio" name="note" id="rating1" value="1">
                </label>
            </li>
                        <li class="note-off">
                <label for="rating2" title="2 / 5">
                    <i class="material-icons">grade</i>
                    <input type="radio" name="note" id="rating2" value="2">
                </label>
            </li>
                        <li class="note-off">
                <label for="rating3" title="3 / 5">
                    <i class="material-icons">grade</i>
                    <input type="radio" name="note" id="rating3" value="3">
                </label>
            </li>
                        <li class="note-off">
                <label for="rating4" title="4 / 5">
                    <i class="material-icons">grade</i>
                    <input type="radio" name="note" id="rating4" value="4">
                </label>
            </li>
                        <li class="note-off">
                <label for="rating5" title="5 / 5">
                    <i class="material-icons">grade</i>
                    <input type="radio" name="note" id="rating5" value="5">
                </label>
            </li>
                        <li class="rating-infos text-muted">
                            Aucune note. Soyez le premier à attribuer une note !
                        </li>
        </ul>
    </form>
</div>
                            
                                                            <div class="plugin plugin-comments" id="comments-blog">
    <p class="h3">Commentaires</p>
            <ul class="media-list">
                        <li class="commment media">
                                <img src="http://www.miamondo.org//medias/static/manager/im/avatar.png?fx=c_50_50" alt="bidouille" width="50" class="rounded mr-2 mr-lg-3">
                                <div class="media-body">
                    <p class="metas">
                        <span>
                            <strong class="meta-count">1</strong> 
                            <span class="meta-author">
                                                                bidouille
                                 
                            </span>
                            <span class="meta-date">Le 14/09/2020</span>
                        </span>
                    </p>
                    <div class="media-description">
                        Le problème de PySimpleGUI, c'est son code. Le paradigme a un potentiel incroyable, mais l'implémentation est trop fragile. La documentation est un cauchemar qui reflète très exactement la qualité du code: monolithique, redondant, désordonné, non pythonique, avec une emphase sur des choses superflues (des milliers de "thèmes" en dur!). En bref, une excellente idée mal exploitée et du coup un beau gâchis :(
                    </div>
                    
                                                                    <div class="comment media by-webmaster mt-4">
                                                        <img src="//www.miamondo.org/medias/static/manager/im/avatar.png?fx=c_50_50" alt="miamondo" width="50" class="img-fluid rounded mr-2 mr-lg-3">
                                                        <div class="media-body">
                                <p class="metas">
                                    <span class="meta-author">miamondo</span>
                                    <span class="meta-date">Le 14/09/2020</span>
                                </p>
                                <div class="media-description">
                                    <p>Salut,</p>

<p>Cest exactement ça. Au départ, j'ai été séduit par le concept mais j'ai très vite constaté que l'ensemble était instable, sans parler de la documentation qui est un vrai capharnaüm... Grosse déception</p>
                                </div>
                            </div>
                        </div>
                                                            </div>
            </li>
                    </ul>
            </div>
                                                      
                                <div class="plugin plugin-comment" id="comment-add">
    <p class="h3">Ajouter un commentaire</p>
    <form method="post" action="http://www.miamondo.org/blog/mon-retour-d-experience-avec-pysimplegui.html#comment-add">
            
                <div class="form-group">
            <label for="comment_field_name" class="required">Nom</label>
            <input type="text" class="form-control" name="name" id="comment_field_name" value="" required>
        </div>
        
        <div class="form-group">
            <label for="comment_field_email">E-mail</label>
            <input type="email" class="form-control" name="email" id="comment_field_email" value="">
        </div>
        
        <div class="form-group">
            <label for="comment_field_url">Site Internet</label>
            <input type="url" class="form-control" name="web" id="comment_field_url" value="">
        </div>
                
        <div class="form-group">
            <div class="control-text-format" data-target="comment_field_message">
    <div class="btn-group">
        <button type="button" class="btn btn-sm" data-tag="[b]" title="Gras"><i class="material-icons">format_bold</i></button>
        <button type="button" class="btn btn-sm" data-tag="[i]" title="Italique"><i class="material-icons">format_italic</i></button>
        <button type="button" class="btn btn-sm" data-tag="[u]" title="Souligné"><i class="material-icons">format_underline</i></button>
        <button type="button" class="btn btn-sm" data-modal="size" title="Taille du texte"><i class="material-icons">text_fields</i></button>
        <div class="d-inline-block dropdown">
            <button type="button" class="btn btn-sm dropdown-toggle" data-toggle="dropdown" title="Couleur du texte"><i class="material-icons">format_color_text</i></button>
            <div class="dropdown-menu control-text-format-colors">
                <span style="background-color:#fefe33"></span>
                <span style="background-color:#fbbc03"></span>
                <span style="background-color:#fb9902"></span>
                <span style="background-color:#fd5308"></span>
                <span style="background-color:#fe2712"></span>
                <span style="background-color:#a7194b"></span>
                <span style="background-color:#8601af"></span>
                <span style="background-color:#3d01a4"></span>
                <span style="background-color:#0247fe"></span>
                <span style="background-color:#0392ce"></span>
                <span style="background-color:#66b032"></span>
                <span style="background-color:#d0ea2b"></span>
                <span style="background-color:#fff"></span>
                <span style="background-color:#ccc"></span>
                <span style="background-color:#999"></span>
                <span style="background-color:#666"></span>
                <span style="background-color:#333"></span>
                <span style="background-color:#000"></span>
                <div class="input-group input-group-sm">
                    <input type="text" class="form-control" maxlength="7" value="" placeholder="#000000">
                    <div class="input-group-append">
                        <button class="btn btn-secondary" type="button"><i class="material-icons">check</i></button>
                    </div>
                </div>
            </div>
        </div>
        <button type="button" class="btn btn-sm" data-modal="quote" title="Citation"><i class="material-icons">format_quote</i></button>
        <button type="button" class="btn btn-sm" data-tag="[center]" title="Texte centré"><i class="material-icons">format_align_center</i></button>
        <button type="button" class="btn btn-sm" data-modal="url" title="Lien"><i class="material-icons">insert_link</i></button>
        <button type="button" class="btn btn-sm" data-modal="spoiler" title="Texte caché"><i class="material-icons">visibility_off</i></button>
        <button type="button" class="btn btn-sm" data-modal="img" title="Image"><i class="material-icons">insert_photo</i></button>
        <button type="button" class="btn btn-sm" data-modal="video" title="Vidéo"><i class="material-icons">movie</i></button>
        <button type="button" class="btn btn-sm" data-tag="[code]" title="Code"><i class="material-icons">code</i></button>
                <button type="button" class="btn btn-sm" data-toggle="smileys" title="Émoticônes"><i class="material-icons">sentiment_satisfied</i></button>
                <button type="button" class="btn btn-sm" data-toggle="preview"><i class="material-icons">check</i> Aperçu</button>
    </div>
</div>            <textarea class="form-control" name="comment" rows="10" cols="1" id="comment_field_message" required></textarea>
                            <div class="control-text-smileys d-none mt-1">
        <button type="button" class="btn btn-link" rel=":1:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/1.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":2:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/2.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":3:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/3.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":4:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/4.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":5:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/5.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":6:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/6.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":7:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/7.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":8:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/8.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":9:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/9.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":10:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/10.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":11:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/11.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":12:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/12.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":13:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/13.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":14:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/14.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":15:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/15.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":16:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/16.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":17:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/17.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":18:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/18.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":19:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/19.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":20:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/20.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":21:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/21.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":22:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/22.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":23:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/23.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":24:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/24.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":25:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/25.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":26:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/26.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":27:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/27.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":28:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/28.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":29:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/29.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":30:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/30.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":31:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/31.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":32:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/32.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":33:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/33.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":34:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/34.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":35:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/35.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":36:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/36.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":37:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/37.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":38:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/38.png" alt="">
    </button>
        <button type="button" class="btn btn-link" rel=":39:">
        <img src="//www.miamondo.org/medias/static/themes/smileys/39.png" alt="">
    </button>
    </div>                    </div>
                    <div class="form-group">
    <span class="fake-label required">Anti-spam</span>
    <div>
        <link href="http://www.miamondo.org/medias/static/icon-captcha/css/icon-captcha.min.css" rel="stylesheet">
        <script src="http://www.miamondo.org/medias/static/icon-captcha/js/icon-captcha.min.js"></script>
        <div class="captcha-holder">&nbsp;</div>
    
        <script>
        $('.captcha-holder').iconCaptcha({
            captchaAjaxFile: '//www.miamondo.org/sessions/iconcaptcha',
            captchaMessages: {
                header: "Quel\u0020est\u0020l\u0027intrus\u0020\u003F",
                correct: {
                        top: "Correct",
                        bottom: "Vous\u0020n\u0027\u00EAtes\u0020pas\u0020un\u0020robot"
                },
                incorrect: {
                        top: "Erreur",
                        bottom: "Vous\u0020avez\u0020s\u00E9lectionn\u00E9\u0020la\u0020mauvaise\u0020image"
                }
            }
        });
        </script>
    </div>
</div>            
      
        <button type="submit" name="s" class="btn btn-primary">Ajouter</button>
    </form>
</div>                                                                                                    </div>
        </div>
    </div>
</div>
            </div>
        </div>
    </div>
</div>
                </section>
            
                                <aside id="sidebar" class="col-lg-3 sticky-top">
                    <div id="sidebar-inner">
                                                                                                                                                                                    <div id="widget-1" class="widget" data-id="widget_searchbox" data-widget-num="1">
                                        <div class="widget-title">
            <span>
                    Rechercher/Serĉi
                </span>
                </div>
                                                                                                                <div class="widget-content">
                                        <form method="get" action="http://www.miamondo.org/search/site/" class="form-search">
    <div class="input-group">
        <div class="input-group-prepend">
            <span class="input-group-text"><i class="material-icons">search</i></span>
        </div>
        <input class="form-control" type="text" name="q" value="" placeholder="Votre recherche" pattern=".{3,}" required>
        <div class="input-group-append">
			<button type="submit" class="btn btn-secondary">OK</button>
		</div>
    </div>
</form>
                                        </div>
                                                                                                </div>
                                                                                                                                                                                                                                                                        <div id="widget-2" class="widget" data-id="widget_visualtext" data-widget-num="2">
                                        <a href="https://youtu.be/a2skpexVzkQ" class="widget-title">
            <span>
                    Vidéo
                </span>
                </a>
                                                                                                                <div class="widget-content">
                                        <p><iframe allowfullscreen="" frameborder="0" height="390" src="https://www.youtube.com/embed/FH_bKFgMWyY" title="YouTube video player" width="640"></iframe></p>

                                        </div>
                                                                                                </div>
                                                                                                                                                                                                                                                                        <div id="widget-3" class="widget" data-id="widget_blogpost_last" data-widget-num="3">
                                        <div class="widget-title">
            <span>
                    Billets récents
                </span>
                </div>
                                                                                                                <div class="widget-content">
                                        <!-- WIDGET : 1 -->
<ul class="media-list blog-items" data-addon="blog">
        <li class="media blog-item" data-date="09/12/2020">
                        <a href="http://www.miamondo.org/blog/mon-retour-d-experience-avec-pysimplegui.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/pysimplegui.png?fx=c_50_50" alt="Pysimplegui" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/mon-retour-d-experience-avec-pysimplegui.html">PySimpleGUI</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 12/09/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="08/19/2020">
                        <a href="http://www.miamondo.org/blog/labortablo-mon-environnement-de-bureau-entierement-code-en-python.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/labortablo-2.png?fx=c_50_50" alt="Labortablo 2" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/labortablo-mon-environnement-de-bureau-entierement-code-en-python.html">Labortablo, mon environnement de bureau entièrement codé en Python</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 19/08/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="08/19/2020">
                        <a href="http://www.miamondo.org/blog/ou-s-arrete-l-infini.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/usvainfinity.svg.png?fx=c_50_50" alt="Usvainfinity svg" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/ou-s-arrete-l-infini.html">Où s'arrête l'infini?</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 19/08/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="07/29/2020">
                        <a href="http://www.miamondo.org/blog/kronik.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/kronik.png?fx=c_50_50" alt="Kronik" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/kronik.html">Kronik</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 29/07/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="07/14/2020">
                        <a href="http://www.miamondo.org/blog/la-planete-archlinux-manuel-d-installation.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/wallpaper.png?fx=c_50_50" alt="Wallpaper" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/la-planete-archlinux-manuel-d-installation.html">La planète Archlinux</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 14/07/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="07/13/2020">
                        <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/politique.html">Politique</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 13/07/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="07/13/2020">
                        <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/liste-des-articles-de-la-rubrique-informatique.html">Informatique</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 13/07/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="07/11/2020">
                        <a href="http://www.miamondo.org/blog/n-oubliez-pas-le-geste-barrier-pour-vos-ordinateurs.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/img-20200711-235548.jpg?fx=c_50_50" alt="Bienvenue dans mon antre" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/n-oubliez-pas-le-geste-barrier-pour-vos-ordinateurs.html">N'oubliez pas le geste Barrier pour vos ordinateurs</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 11/07/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="06/24/2020">
                        <a href="http://www.miamondo.org/blog/la-nature-sous-licence-libre.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/tarfala.jpg?fx=c_50_50" alt="Tarfala" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/la-nature-sous-licence-libre.html">La nature sous licence libre</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 24/06/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="06/17/2020">
                        <a href="http://www.miamondo.org/blog/a-la-decouverte-de-flask.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/scrot-5-000.png?fx=c_50_50" alt="Scrot 5 000" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/a-la-decouverte-de-flask.html">À la découverte de Flask</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 17/06/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="05/17/2020">
                        <a href="http://www.miamondo.org/blog/peut-on-rever-d-un-nouveau-monde-sous-licence-libre.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/annotation-2020-05-16-233704.png?fx=c_50_50" alt="Annotation 2020 05 16 233704" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/peut-on-rever-d-un-nouveau-monde-sous-licence-libre.html">Peut-on rêver d'un nouveau monde sous licence libre?</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 17/05/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="05/10/2020">
                        <a href="http://www.miamondo.org/blog/envole-moi.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/2014-nordwestufer-wittow-06-2.jpg?fx=c_50_50" alt="2014 nordwestufer wittow 06 2" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/envole-moi.html">Envole-moi</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 10/05/2020</span>
            </p>
                    </div>
            </li>
    </ul>
                                        </div>
                                                                                                </div>
                                                                                                                                                                                                                                                                        <div id="widget-4" class="widget" data-id="widget_blogpost_mostviewed" data-widget-num="4">
                                        <div class="widget-title">
            <span>
                    Billets les plus consultés
                </span>
                </div>
                                                                                                                <div class="widget-content">
                                        <!-- WIDGET : 1 -->
<ul class="media-list blog-items" data-addon="blog">
        <li class="media blog-item" data-date="06/24/2020">
                        <a href="http://www.miamondo.org/blog/la-nature-sous-licence-libre.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/tarfala.jpg?fx=c_50_50" alt="Tarfala" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/la-nature-sous-licence-libre.html">La nature sous licence libre</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 24/06/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-category="sciences" data-date="02/16/2020">
                        <a href="http://www.miamondo.org/blog/sciences/la-distorsion-de-l-espace-temps-et-les-voyages-supraluminiques.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/800px-alcubierre.png?fx=c_50_50" alt="800px alcubierre" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/sciences/la-distorsion-de-l-espace-temps-et-les-voyages-supraluminiques.html">La distorsion de l'espace-temps et les voyages supraluminiques</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 16/02/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="02/23/2020">
                        <a href="http://www.miamondo.org/blog/j-ai-liber-e-mon-smartphone.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/e-smartphone.png?fx=c_50_50" alt="E smartphone" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/j-ai-liber-e-mon-smartphone.html">J'ai libér/é/ mon smartphone</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 23/02/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="05/04/2020">
                        <a href="http://www.miamondo.org/blog/la-boucle-infinie-expliquee-en-musique.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/bolero-theme-manuscrit.png?fx=c_50_50" alt="Bolero theme manuscrit" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/la-boucle-infinie-expliquee-en-musique.html">La boucle infinie expliquée en musique</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 04/05/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="05/10/2020">
                        <a href="http://www.miamondo.org/blog/envole-moi.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/2014-nordwestufer-wittow-06-2.jpg?fx=c_50_50" alt="2014 nordwestufer wittow 06 2" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/envole-moi.html">Envole-moi</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 10/05/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="08/19/2020">
                        <a href="http://www.miamondo.org/blog/labortablo-mon-environnement-de-bureau-entierement-code-en-python.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/labortablo-2.png?fx=c_50_50" alt="Labortablo 2" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/labortablo-mon-environnement-de-bureau-entierement-code-en-python.html">Labortablo, mon environnement de bureau entièrement codé en Python</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 19/08/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="03/01/2020">
                        <a href="http://www.miamondo.org/blog/calculatrice.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/kalkulilo.png?fx=c_50_50" alt="Kalkulilo" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/calculatrice.html">Calculatrice programmée en Python</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 01/03/2020</span>
            </p>
                    </div>
            </li>
        <li class="media blog-item" data-date="03/07/2020">
                        <a href="http://www.miamondo.org/blog/massoud-l-insoumis.html" class="media-object">
            <img src="http://www.miamondo.org/medias/images/massoud.png?fx=c_50_50" alt="Massoud" class="img-fluid">
        </a>
                <div class="media-body">
            <p class="media-heading">
                <a href="http://www.miamondo.org/blog/massoud-l-insoumis.html">Massoud l'insoumis</a>
                                            </p>
            
            <p class="metas">
                                <span class="meta-author">
                                        <span>
                        Par 
                        <a href="www.miamondo.org/do/author/5e49189107d6b96c0b00561e" rel="author" class="meta-name">miamondo</a>
                    </span>
                </span>
                                <span class="meta-date">Le 07/03/2020</span>
            </p>
                    </div>
            </li>
    </ul>
                                        </div>
                                                                                                </div>
                                                                                                                                                                                                                                                                        <div id="widget-5" class="widget" data-id="widget_blogpost_categories" data-widget-num="5">
                                        <a href="http://miamondo.e-monsite.com/" class="widget-title">
            <span>
                    <img src="http://miamondo.e-monsite.com/medias/images/img-20200216-184557.png" alt="Cybercarnet" class="img-fluid">
                </span>
                </a>
                                                                                                                <div class="widget-content">
                                        <div class="list-group blog-categories" data-addon="blog">
                                                        <a class="blog-category list-group-item list-group-item-action d-flex align-items-center" data-category="sciences" href="http://www.miamondo.org/blog/sciences/">
                                        Sciences
                    <span class="badge ml-auto badge-count">2</span>
                </a>
                                                                                <a class="blog-category list-group-item list-group-item-action d-flex align-items-center" data-category="philosophie-et-sipritualites" href="http://www.miamondo.org/blog/philosophie-et-sipritualites/">
                                        Philosophie & spiritualités
                    <span class="badge ml-auto badge-count">2</span>
                </a>
                                                                                <a class="blog-category list-group-item list-group-item-action d-flex align-items-center" data-category="litterature" href="http://www.miamondo.org/blog/litterature/">
                                        Littérature
                    <span class="badge ml-auto badge-count">4</span>
                </a>
                                                                                <a class="blog-category list-group-item list-group-item-action d-flex align-items-center" data-category="esperanto" href="http://www.miamondo.org/blog/esperanto/">
                                        Espéranto
                    <span class="badge ml-auto badge-count">1</span>
                </a>
                                                                                <a class="blog-category list-group-item list-group-item-action d-flex align-items-center" data-category="mon-herbier" href="http://www.miamondo.org/blog/mon-herbier/">
                                        Mon herbier
                    <span class="badge ml-auto badge-count">2</span>
                </a>
                                        </div>
                                        </div>
                                                                                                </div>
                                                                                                                                                                                                                                                                        <div id="widget-6" class="widget" data-id="widget_tagscloud" data-widget-num="6">
                                        <div class="widget-title">
            <span>
                    Nuages de tags
                </span>
                </div>
                                                                                                                <div class="widget-content">
                                        <div class="widget-tags tag-line">
                                        <a href="http://www.miamondo.org/blog/do/tag/alcubierre/" class="btn btn-outline-secondary btn-sm">Alcubierre</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/amour/" class="btn btn-outline-secondary btn-sm">Amour</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/archlinux/" class="btn btn-outline-secondary btn-sm">Archlinux</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/blog/" class="btn btn-outline-secondary btn-sm">blog</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/chartreux/" class="btn btn-outline-secondary btn-sm">Chartreux</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/cms/" class="btn btn-outline-secondary btn-sm">CMS</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/configuration/" class="btn btn-outline-secondary btn-sm">configuration</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/covid-19/" class="btn btn-outline-secondary btn-sm">Covid-19</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/delice/" class="btn btn-outline-secondary btn-sm">Délice</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/herbier/" class="btn btn-outline-secondary btn-sm">herbier</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/hebergement/" class="btn btn-outline-secondary btn-sm">hébergement</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/licence-libre/" class="btn btn-outline-secondary btn-sm">licence libre</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/linux/" class="btn btn-outline-secondary ">Linux</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/nature/" class="btn btn-outline-secondary btn-sm">nature</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/poo/" class="btn btn-outline-secondary btn-sm">POO</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/programmation/" class="btn btn-outline-secondary btn-sm">programmation</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/python/" class="btn btn-outline-secondary ">Python</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/resistance/" class="btn btn-outline-secondary btn-sm">résistance</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/revolution/" class="btn btn-outline-secondary btn-sm">révolution</a>
                                        <a href="http://www.miamondo.org/blog/do/tag/tkinter/" class="btn btn-outline-secondary btn-sm">Tkinter</a>
    </div>
                                        </div>
                                                                                                </div>
                                                                                                                                                                                                                                                                        <div id="widget-7" class="widget" data-id="widget_newsletter" data-widget-num="7">
                                        <div class="widget-title">
            <span>
                    Informletero (Lettre d'information)
                </span>
                </div>
                                                                                                                <div class="widget-content">
                                        <form action="http://www.miamondo.org/newsletters/subscribe" method="post">
    <div class="input-group">
        <div class="input-group-prepend">
			<span class="input-group-text"><i class="material-icons">mail_outline</i></span>
		</div>
        <input class="form-control" id="email" type="email" name="email" value="" placeholder="E-mail">
        <div class="input-group-append">
            <button type="submit" class="btn btn-primary">OK</button>
        </div>
    </div>
</form>
                                        </div>
                                                                                                </div>
                                                                                                                                                </div>
                </aside>
            </div>
                    </div>
        <!-- //WRAPPER -->
        
                <footer id="footer" class="frieze-triangles">
                        <div class="container">
                                
                                
                            </div>
                
                            <ul id="legal-mentions" class="footer-mentions">
    
        <li><a href="http://www.miamondo.org/about/cgu">Conditions générales d'utilisation</a></li>
    
    
    </ul>                    </footer>
                
                
                
            

 
    
			
		    
			
			
						 	 





        
                <a href="javascript:void(0)" id="scroll-to-top" onclick="$('html, body').animate({ scrollTop:0}, 600);">
            <i class="material-icons md-lg">expand_less</i>
        </a>
            </body>
</html>